Resolved
Thank you for your patience and support during while we got back online today. If you have any pending or unprocessed transactions, please contact support@paybis.com
Posted Oct 20, 2025 - 20:42 UTC
Update
We are seeing improvements and the service available again. Some residual delays may still occur while recovery completes. We’re monitoring closely and will provide further updates as needed.
Posted Oct 20, 2025 - 20:12 UTC
Update
No new updates from our infrastructure provider. We are closely monitoring the situation and will share further updates as they become available.
Posted Oct 20, 2025 - 19:31 UTC
Update
We are seeing gradual improvements from our infrastructure provider. Previously created transactions have started processing. We’re monitoring closely and will provide further updates as recovery continues.
Posted Oct 20, 2025 - 18:48 UTC
Update
Our infrastructure provider’s mitigations are progressing, and they are observing early signs of recovery in some areas. Work is ongoing to restore stability across all systems, after which connectivity and service performance are expected to fully recover.
We continue to monitor the situation closely and will provide further updates as progress is made.
Posted Oct 20, 2025 - 17:55 UTC
Update
Our infrastructure provider continues to apply mitigation steps and is seeing steady recovery in service connectivity. An additional measures are being implemented to fully restore normal operations.
We are closely monitoring the progress and will provide further updates as needed.
Posted Oct 20, 2025 - 17:09 UTC
Update
Our infrastructure provider has narrowed down the source of the connectivity issues and is actively implementing mitigations to restore stability. We’re monitoring closely and will share further updates as progress continues.
Posted Oct 20, 2025 - 15:57 UTC
Update
Our infrastructure provider has identified the source of the connectivity issues and is actively implementing mitigations to restore full stability.
We continue to monitor the situation closely and will provide further updates as progress is made.
Posted Oct 20, 2025 - 15:18 UTC
Update
Our infrastructure provider is seeing early signs of recovery for the connectivity issues and continues to investigate the root cause.
We’re monitoring closely and will share further updates as we learn more.
Posted Oct 20, 2025 - 15:02 UTC
Update
Our infrastructure provider is seeing early signs of recovery for the connectivity issues and continues to investigate the root cause.
We’re monitoring closely and will share further updates as we learn more.
Posted Oct 20, 2025 - 14:40 UTC
Update
Our infrastructure provider continues to work toward a full resolution.
We are actively investigating the transaction processing issue, and due to the broader incident our public API is currently experiencing an outage.
We’re working to restore service as quickly as possible and will provide further updates as progress is made.
Posted Oct 20, 2025 - 14:04 UTC
Update
Our infrastructure provider continues to work toward a full resolution. In parallel, we are actively investigating the transaction processing issue and implementing mitigations.
We’ll provide further updates as progress is made.
Posted Oct 20, 2025 - 13:26 UTC
Update
Our infrastructure provider is actively working toward a full resolution.
We can confirm that transaction creation has been restored, however transaction processing remains partially degraded.
We continue to monitor the situation closely and will provide further updates as progress is made.
Posted Oct 20, 2025 - 12:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 11:59 UTC
Update
AWS reports that services in US-EAST-1 (N. Virginia) are still experiencing increased error rates and they are continuing to work toward full resolution. We’re monitoring closely and will keep you informed of further progress.
Posted Oct 20, 2025 - 10:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 10:24 UTC
Update
AWS has identified the root cause of the issue in the US-EAST-1 (N. Virginia) region and is actively working on a resolution.
We continue to monitor the situation and will provide further updates as progress is made.
Posted Oct 20, 2025 - 10:22 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:53 UTC
Investigating
Dear Valued Partners,
We would like to inform you that we are currently experiencing partial service degradation due to ongoing operational issues in the AWS US-EAST-1 (N. Virginia) region.
We understand the importance of our services to you, and we want to assure you that we are doing everything we can to rectify the situation.
We thank you for your patience and understanding during this time and will provide updates as soon as they become available.
Sincerely,
The Paybis Team
Posted Oct 20, 2025 - 07:29 UTC
This incident affected: Payment Methods (Credit Cards, Apple Pay, Google Pay, UK Bank Instant, Bank Transfer Nigeria, Bank Transfer Vietnam, Bank Transfer Singapore, Bank Transfer EU, Skrill, PIX, Giropay, Khipu, WebPay, PSE, SPEI, Neteller, Trustly), Crypto Payouts (Bitcoin (BTC), Ethereum (ETH), Bitcoin Cash (BCH), Litecoin (LTC), Ripple (XRP), Binance Coin (BNB), Stellar (XLM), Tron (TRX), Tether (USDT), Tether (USDT-TRC20), Binance Coin (BSC), Dogecoin (DOGE), USD Coin (USDC), Chainlink (LINK), Shiba Inu (SHIB), Uniswap (UNI), Aave (AAVE), Compound (COMP), Maker (MKR), Yearn Finance (YFI), Sushi (SUSHI), Enjin (ENJ), Chiliz (CHZ), Basic Attention Token (BAT), Perpetual Protocol (PERP), Swipe (SXP), Curve DAO Token (CRV), Numeraire (NMR), Holo (HOT), Kyber Network (KNC), The Sandbox (SAND), DAI Coin (DAI), Wrapped Bitcoin (WBTC), Cardano (ADA), Solana (SOL), Polkadot (DOT), Binance USD (BUSD), Polygon (POL), Tezos (XTZ), Axie Infinity (AXS)), Web (Frontend), Mob (Mobile SDK), Partner Portal, API, Support Live Chat, and Sandbox Environment (Sandbox - Web (Frontend), Sandbox - Mob (Mobile SDK), Sandbox - Partner Portal, Sandbox - Email Notifications, Sandbox - API).