Intermittent delays in Polygon network transaction processing

Incident Report for Paybis On Off Ramp

Resolved

This incident has been resolved.
Posted Nov 23, 2025 - 09:29 UTC

Identified

We have identified the issue causing intermittent transaction processing delays and are actively working on a resolution. Updates will be provided as more information becomes available.
Posted Nov 23, 2025 - 05:09 UTC

Investigating

We are currently investigating this issue.
Posted Nov 23, 2025 - 03:11 UTC
This incident affected: Crypto Payouts (Polygon (POL)).