Technical difficulties with log into the service
Incident Report for Paybis On/Off Ramp
Resolved
This incident has been resolved.
Posted May 27, 2024 - 14:09 UTC
Investigating
Dear Customers,

We would like to inform you that our service is currently experiencing technical difficulties related to logging into the system. Our team is already working on resolving this issue and is doing everything possible to restore normal operations as soon as possible.

We apologize for any inconvenience this may have caused and thank you for your patience and understanding. We will keep you updated on any changes and progress in resolving this situation.

If you have any questions or need assistance, please contact our support team.

Sincerely,
Paybis Team



Technical difficulties with log into the service
Posted May 27, 2024 - 13:50 UTC
This incident affected: Email Notifications.