Intermediate delays in Polygon network transaction processing

Incident Report for Paybis On Off Ramp

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 13:39 UTC

Investigating

We are currently investigating this issue.
Posted Jul 16, 2026 - 12:48 UTC
This incident affected: Crypto Payouts (Solana (SOL), Polygon (POL), Tether (USDT-Polygon)).