Apple Pay is temporarily unavailable
Incident Report for Paybis On/Off Ramp
Resolved
This incident has been resolved.
Posted Oct 16, 2023 - 13:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2023 - 12:33 UTC
Investigating
Dear valued partners,
We regret to inform you that Apple Pay is temporarily unavailable. We are working diligently to resolve the issue and apologize for any inconvenience this may cause.
Thank you for your patience and understanding.
Posted Oct 16, 2023 - 12:31 UTC
This incident affected: Payment Methods (Apple Pay).