Spike in the BTC network fees
Incident Report for Paybis On/Off Ramp
Resolved
This incident has been resolved.
Posted Jun 08, 2023 - 06:21 UTC
Monitoring
Dear Partners,

Due to the spike in the BTC network fees, we are forced to increase the minimum transaction amount from 5 USD to 20 USD for all payment methods, until further notice.

Thank you for your patience,
Paybis team.
Posted May 08, 2023 - 16:23 UTC
This incident affected: Crypto Payouts (Bitcoin (BTC)).