Spike in the BTC network fees
Incident Report for Paybis On/Off Ramp
Resolved
This incident has been resolved.
Posted Jan 31, 2024 - 16:45 UTC
Update
The payout time for Bitcoin (BTC) transactions will be extended from 10 to 30 minutes in an effort to mitigate the impact of increased network fees.
Posted Dec 19, 2023 - 15:52 UTC
Monitoring
Dear Partners,

Due to the recent surge in Bitcoin (BTC) network fees, we must increase the minimum transaction amount from 5 USD to 50 USD across all payment methods.

We sincerely apologize for any inconvenience this may cause. This situation is beyond our control. Rest assured, our team is closely monitoring the network, and we will revert the transaction limits to their normal values as soon as the network fees stabilize.

Best regards,
The Paybis Team
Posted Dec 17, 2023 - 18:16 UTC
This incident affected: Crypto Payouts (Bitcoin (BTC)).