Temporary Transaction Processing Delays

Incident Report for Paybis On Off Ramp

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 06:19 UTC

Monitoring

Please note that Paybis is now 100% operational and your transactions will complete.

If you have incomplete or rejected transactions, you should now be able to process them.

Thank you for your patience and understanding while we addressed technical issues affecting transaction processing. This was due to issues with a third party that have now been resolved.

We are closely monitoring the situation and have taken steps to minimise transaction processing challenges in the future.

As always, our support team is on hand if you need assistance.
The Paybis Team
Posted Jan 07, 2026 - 10:48 UTC
This incident affected: Crypto Payouts (Bitcoin (BTC), Ethereum (ETH), Bitcoin Cash (BCH), Litecoin (LTC), Ripple (XRP), Binance Coin (BNB), Stellar (XLM), Tron (TRX), Tether (USDT), Tether (USDT-TRC20), Binance Coin (BSC), Dogecoin (DOGE), USD Coin (USDC), Chainlink (LINK), Shiba Inu (SHIB), Uniswap (UNI), Aave (AAVE), Compound (COMP), Maker (MKR), Yearn Finance (YFI), Sushi (SUSHI), Enjin (ENJ), Chiliz (CHZ), Basic Attention Token (BAT), Perpetual Protocol (PERP), Swipe (SXP), Curve DAO Token (CRV), Numeraire (NMR), Holo (HOT), Kyber Network (KNC), The Sandbox (SAND), DAI Coin (DAI), Wrapped Bitcoin (WBTC), Cardano (ADA), Solana (SOL), Polkadot (DOT), Binance USD (BUSD), Polygon (POL), Tezos (XTZ), Axie Infinity (AXS)).