Completed
The scheduled maintenance has been completed.
Posted Mar 26, 2026 - 09:02 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2026 - 07:00 UTC
Scheduled
Scheduled Maintenance — 26 March 2026
07:00–12:00 UTC | 08:00–13:00 CET | 09:00–14:00 EET
Dear Valued Partners,
We would like to inform you about scheduled infrastructure maintenance taking place on Thursday, 26 March 2026.
During this time, Paybis services and endpoints, including APIs and partner integrations, will remain operational. However, you may experience minor, temporary delays in transaction processing, as well as short-term latency or intermittent behavior across some services.
Please be assured that all transactions will remain secure and will be fully processed and honored. This maintenance is part of our ongoing efforts to improve the stability, security, and reliability of the Paybis platform. Our team will closely monitor the process to ensure it is completed as smoothly and efficiently as possible.
Thank you for your understanding and continued partnership. If you have any questions or require assistance, please feel free to contact our Support team.
Warm regards,
The Paybis Team
Posted Mar 18, 2026 - 17:55 UTC
This scheduled maintenance affected: Payment Methods (Credit Cards, Apple Pay, Google Pay, UK Bank Instant, Bank Transfer Nigeria, Bank Transfer Vietnam, Bank Transfer Singapore, Bank Transfer EU, Skrill, PIX, Giropay, Khipu, WebPay, PSE, SPEI, Neteller, Trustly), Crypto Payouts (Bitcoin (BTC), Ethereum (ETH), Bitcoin Cash (BCH), Litecoin (LTC), Ripple (XRP), Binance Coin (BNB), Stellar (XLM), Tron (TRX), Tether (USDT), Tether (USDT-TRC20), Binance Coin (BSC), Dogecoin (DOGE), USD Coin (USDC), Chainlink (LINK), Shiba Inu (SHIB), Uniswap (UNI), Aave (AAVE), Compound (COMP), Maker (MKR), Yearn Finance (YFI), Sushi (SUSHI), Enjin (ENJ), Chiliz (CHZ), Basic Attention Token (BAT), Perpetual Protocol (PERP), Swipe (SXP), Curve DAO Token (CRV), Numeraire (NMR), Holo (HOT), Kyber Network (KNC), The Sandbox (SAND), DAI Coin (DAI), Wrapped Bitcoin (WBTC), Cardano (ADA), Solana (SOL), Polkadot (DOT), Binance USD (BUSD), Polygon (POL), Tezos (XTZ), Axie Infinity (AXS), Tether (USDT-Polygon)), Web (Frontend), Partner Portal, API, Mob (Mobile SDK), Email Notifications, Support Live Chat, and Sandbox Environment (Sandbox - Web (Frontend), Sandbox - Mob (Mobile SDK), Sandbox - Partner Portal, Sandbox - Email Notifications, Sandbox - API).