Issue with sending emails notifications
Incident Report for Paybis On/Off Ramp
Resolved
This incident has been resolved.
Posted Apr 30, 2023 - 15:29 UTC
Investigating
Dear Partners,

Due to technical problems, emails notifications is temporarily not working.

Thank you for your patience,
Paybis team
Posted Apr 30, 2023 - 14:35 UTC
This incident affected: Email Notifications.