Intermediate delays in Ripple (XRP) transaction processing

Incident Report for Paybis On Off Ramp

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 10:05 UTC

Identified

Dear Valued Partners,

We are currently experiencing intermittent delays in Ripple (XRP) transaction processing.

Our team is actively working to restore normal processing times as soon as possible.

Thank you for your patience and understanding,
The Paybis Team
Posted Jan 28, 2026 - 07:27 UTC
This incident affected: Crypto Payouts (Ripple (XRP)).