Your use of Paybis may be affected

Incident Report for Paybis On Off Ramp

Resolved

This incident has been resolved.
Posted May 09, 2026 - 13:09 UTC

Identified

Your use of Paybis may be affected
We are investigating an issue which may affect your use of Paybis.
Thank you for your patience while we resolve this issue.
Please keep checking this page for updates if you experience any reduction in your Paybis service.

Team Paybis
Posted May 08, 2026 - 09:43 UTC
This incident affected: Payment Methods (Credit Cards, Apple Pay, Google Pay, UK Bank Instant, Bank Transfer Nigeria, Bank Transfer Vietnam, Bank Transfer Singapore, Bank Transfer EU, Skrill, PIX, Giropay, Khipu, WebPay, PSE, SPEI, Neteller, Trustly, M-Pesa), Crypto Payouts (Bitcoin (BTC), Ethereum (ETH), Bitcoin Cash (BCH), Litecoin (LTC), Ripple (XRP), Binance Coin (BNB), Stellar (XLM), Tron (TRX), Tether (USDT), Tether (USDT-TRC20), Binance Coin (BSC), Dogecoin (DOGE), USD Coin (USDC), Chainlink (LINK), Shiba Inu (SHIB), Uniswap (UNI), Aave (AAVE), Compound (COMP), Maker (MKR), Yearn Finance (YFI), Sushi (SUSHI), Enjin (ENJ), Chiliz (CHZ), Basic Attention Token (BAT), Perpetual Protocol (PERP), Swipe (SXP), Curve DAO Token (CRV), Numeraire (NMR), Holo (HOT), Kyber Network (KNC), The Sandbox (SAND), DAI Coin (DAI), Wrapped Bitcoin (WBTC), Cardano (ADA), Solana (SOL), Polkadot (DOT), Binance USD (BUSD), Polygon (POL), Tezos (XTZ), Axie Infinity (AXS), Tether (USDT-Polygon)), Web (Frontend), Paybis Web (Corporate), Partner Portal, API, Mob (Mobile SDK), Email Notifications, Support Live Chat, and Sandbox Environment (Sandbox - Web (Frontend), Sandbox - Mob (Mobile SDK), Sandbox - Partner Portal, Sandbox - Email Notifications, Sandbox - API).